BlackBerry OS 7.1.0.649 Leaked

The OS is compatible with BlackBerry Bold 9900/9930, Bold 9790, Curve 9360, Torch 9850 and P’9981. The leak is not an official version and there is no communication from RIM as to the authenticity of the leaked OS. CrackBerry has reported that the unofficial release wouldn’t be supported by either RIM or your carrier.

We do not recommend upgrading your handset either with this unofficial release but, if you do feel that you need to give this a try, you may head on to the CrackBerry forums and download the relevant files.

 

Please, do give the forums a read through to find any problems that other users have reported so you don’t get find yourself with a non-working handset.